图片 两种思科路由器限速方法详解_澳门威尼斯人官网_赌城推荐**

澳门威尼斯人官网_赌城推荐**

当前位置:主页 > 电脑教程 > 网络知识 > 路由器 > 路由器限速 > >

两种思科路由器限速方法详解

来源::未知 | 作者:澳门威尼斯人官网_赌城推荐** | 本文已影响
    大家都知道,不同的路由器限速的方法都不相同,下面我就主要针对思科路由器,详细介绍思科路由器如何限速及其方法。
一、思科路由器NVAR限速
现在的bt软件封锁后会自动改端口,一些软件还是用到8000、8080、2070等端口,限制这些端口这样网络不正常,所以要使用NVAR(Network-Based Application Recognition,网络应用识别),NBAR (Network-Based Application Recognition)的意思是网络应用识别。
NBAR是一种动态能在四到七层寻找协议的技术,它不但能做到普通ACL能做到那样控制静态的、简单的网络应用协议TCP/UDP的端口号。例如我们熟知的WEB应用使用的TCP 80,也能做到控制一般ACLs不能做到动态的端口的那些协议,例如VoIP使用的H.323,SIP等。
要实现对BT流量的控制,就要在思科路由器上实现对PDLM的支持。PDLM是Packet Description Language Module的所写,意思是数据包描述语言模块。它是一种对网络高层应用的协议层的描述,例如协议类型,服务端口号等。它的优势是让NBAR适应很多已有的网络应用,像HTTP URL,DNS,FTP,VoIP等,同时它还可以通过定义,来使NBAR支持许多新兴的网络应用。例如peer2peer工具。PDLM在思科的网站上可以下载,并且利用PDLM可以限制一些网络上的恶意流量。
思科在其官方网站提供了三个PDLM模块,分别为KAZAA2.pdlm,bittorrent.pdlm.emonkey.pdlm可以用来封锁KAZAA,BT,电驴得到PDLM然后通过TFTP服务器将bittorrent.pdlm拷贝到路由中。利用ip nbar pdlm bittorrent.pdlm命令将NBAR中的BT功能启动。再创建一个class-map和policy map并且把它应用到相应的思科路由器的接口上。一般是连接Internet (Chinanet )的接口是FastEthernet或10M的以太网接口。在思科路由器上您可以看见如下的配置 :
class-map match-all bittorrent 
match protocol bittorrent 


policy-map bittorrent-policy 
class bittorrent 
drop 

interface FastEthernet0/ 
description neibujiekou 
ip address 192.168.0.1 255.255.255.0 
ip nat inside  
service-policy input bittorrent-policy  
service-policy output bittorrent-policy 
!
NBAR和PDLM也可以应用在您公司和单位的内联广域网上,可以保证广域网带宽的合理使用。
二、思科路由器端口限速
要限制某项服务,就必须在路由器上设置ACL(访问控制列表)将该服务所用的端口封掉,从而阻止该服务的正常运行。对BT软件,我们可以尝试封它的端口。通常,BT软件使用的是6880-6890端口,在核心思科路由器上使用以下命令将6880-6890端口全部封锁。
(1)禁止下载
access-list 130 deny tcp any any range 6881 6890 
access-list 130 deny tcp any range 6881 6890 any 
ip access-group 130 in / out
(2)限速
access-list 130 remark bt 
access-list 130 permit tcp any any range 6881 6890 
access-list 130 permit tcp any range 6881 6890 any 
rate-limit input access-group 130 712000 8000 8000 conform-action transmit exceed-action drop 
rate-limit output access-group 130 712000 8000 8000 conform-action transmit exceed-action drop
通过以上的设置,您就可以在你的公司或单位的因特网接入思科路由器上实施一些流量控制,从而解决了大家限速难的问题了。

澳门威尼斯人官网_赌城推荐**

热榜阅读TOP

本周TOP10

IP-COM无线路由器限速设置教程

IP-COM无线路由器限速设置教程

很多时候,我们都需要用到路由器的带宽控制和限速功能,宽带控制可以限制内网计算机上网的通信流量,可以...